ugrás a tartalomhoz

Letsencrypt

Theo76 · Júl. 24. (K), 23.15
Sziasztok!

A Letsencrypt-et akartam beállítani. Cloud szerver, Ubuntu 18.04 rendszer + Apache.
Megcsináltam a vhost beállítást:

<VirtualHost domain.hu:80>

<------>ServerName domain.hu
<------>ServerAlias www.domain.hu

<------>DocumentRoot "/var/www/domain/htdocs"

<------><Directory /var/www/domain/htdocs>

<------><------>allow from all
<------><------>Options ExecCGI FollowSymLinks MultiViews SymLinksIfOwnerMatch
<------><------>Require all granted
<------><------>Order Allow,Deny

<------></Directory>

<------>RewriteEngine on
<------>RewriteCond %{SERVER_NAME} =domain.hu [OR]
<------>RewriteCond %{SERVER_NAME} =www.domain.hu
<------>RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,QSA,R=premanent]
<------>
</VirtualHost>
majd a certbot lefutása után ezt kaptam...

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: domain.hu
   Type:   unauthorized
   Detail: Invalid response from
   http://domain.hu/.well-known/acme-challenge/eNfp4RCv99UiQB-8K_y41Z1hmC4WN-KVUNY073lHD9I:
   "<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
   <html><head>
   <title>403 Forbidden</title>
   </head><body>
   <h1>Forbidden</h1>
   <p"

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address.
Mi lehet a gond?
 
1

Rewrite?

T.G · Júl. 25. (Sze), 06.18
Nekem még sosem kellett ilyet beállítanom, így előfordulhat, hogy butaságot kérdezek. :)

A Letsencrypt beüzemelése előtt biztos kell a https-re való átdobás? Nekem úgy lenne logikus, hogy azt majd csak akkor tenném oda, amikor már biztosan működik.
2

igen azt közben kivettem...

Theo76 · Júl. 25. (Sze), 06.37
igen azt közben kivettem...
3

Jogosultság ellenőrzés?

T.G · Júl. 25. (Sze), 07.08
A megadott hivatkozásra milyen választ adsz? Nem tudom mit vár a Letsencrypt. Ám gyanús, hogy a 403-as hibaoldal az nem oké.
4

Melyik hivatkozásra

Theo76 · Júl. 25. (Sze), 07.53
Melyik hivatkozásra gondolsz?
Megcsináltam ezt a configot, majd a certbot --apache -d domain.hu -d www.domain.hu parancsot futtattam le.
5

Invalid response from ...

T.G · Júl. 25. (Sze), 08.47
A hibaüzenet elégé beszédes, érvénytelen válasz érkezett a .../.well-known/acme-challenge/... kérésre.
6

Nah igen... Csak épp ez a

Theo76 · Júl. 25. (Sze), 08.58
Nah igen... Csak épp ez a könyvtár nem létezik. Elvileg neki kellene létrehozni. Gondolom, mert nem az oldal tartalma. Könytárjogosultságok rendben vannak.

Ha létrehozom is ugyan az az eredmény.
7

Ugyanaz, mi?

T.G · Júl. 25. (Sze), 10.12
Ha létrehozod, akkor nem 403-as hibaoldal lesz az eredmény, gondolom én, így szerintem már valami más hibaüzenetet kellene kapnod.
8

Én is ezt hittem... De ugyan

Theo76 · Júl. 25. (Sze), 10.18
Én is ezt hittem... De ugyan az a hiba. Ami a fura, hogy én már csináltam ilyet egy másik szerveren ugyan ezekkel a paraméterekkel, és ott csont nélkül ment...
9

És a böngészőben?

T.G · Júl. 25. (Sze), 10.25
És tényleg, a böngészőben megnézve nem hibaoldalt kapsz, de a Letcencrypt mégis hibaoldalt olvas? Kezd gyanús lenni, hogy valami el van nézve....
10

A böngészőben is hiba, de

Theo76 · Júl. 25. (Sze), 10.42
A böngészőben is hiba, de egyszerűen nem jövök rá, hogy miért... Illetve elvileg ezt a könyvtárat autómatikusan hozzná létre... De nem tudja. Ha én hozom létre nem jó... Pedig 0777es a jogosultság mindenhol az adott könyvtárakban
11

Más probléma

T.G · Júl. 25. (Sze), 13.49
Igen, itt akkor már más problémáról beszélünk, mint amit írtál a témaindítóban.

Elsőre mindenképpen juss el oda, hogy amit te létrehoztál manuálisan az látható legyen.
Egyáltalán a domain-en belül bármi működik? Csak egyedül ez az újonnan feltöltött fájl nem?
12

Amit én létrehoztam, az

Theo76 · Júl. 25. (Sze), 21.09
Amit én létrehoztam, az teljesen látható, megjelenik. A gond ott kezdődik, mikor kiadom a certbot parancsot. Keresi a domain.hu/.well-known/acme-challenge/jDc9dBwlWbMoYxSV6OcYfy3TpL9T6XIC1ZMSPVjrqPo
Csakhogy ez eleve nem létezik, a certbot hozná létre. Így normál módban a cím működik, csak az ssl-t nem lehet megcsinálni.
13

létrehoztam a könyvtárat

Theo76 · Júl. 25. (Sze), 22.04
létrehoztam a könyvtárat kézzel. Működik is. az eredmény viszont ugyan az mint eddig.