ugrás a tartalomhoz

Curl telepítés és beállítás

simisoma · Júl. 2. (H), 15.43
Sziasztok,

van egy kis problémám. PHP-ben CURL-t kéne használjam, de nincs telepítve / engedélyezve.

Próbáltam telepíteni:

apt-get install php5-curl

De nem tudja letölteni:

Csomaglisták olvasása... Kész
Függőségi fa építése
Állapotinformációk olvasása... Kész
Az alábbi extra csomagok kerülnek telepítésre:
libapache2-mod-php5 php5-cli php5-common php5-gd php5-mcrypt php5-mysql
php5-readline
Javasolt csomagok:
php-pear php5-user-cache
Az alábbi ÚJ csomagok lesznek telepítve:
php5-curl
Az alábbi csomagok frissítve lesznek:
libapache2-mod-php5 php5-cli php5-common php5-gd php5-mcrypt php5-mysql
php5-readline
7 frissített, 1 újonnan telepített, 0 eltávolítandó és 249 nem frissített.
Letöltendő adatmennyiség: 5.195 kB.
A művelet után 204 kB lemezterület kerül felhasználásra.
Folytatni akarja? [I/n] I
FIGYELMEZTETÉS: Az alábbi csomagok nem hitelesíthetők!
php5-mysql php5-readline php5-cli php5-mcrypt php5-gd libapache2-mod-php5
php5-common php5-curl
Valóban ellenőrzés nélkül telepíti a csomagokat? [i/N] i
Hiba http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/ trusty/main php5-mysql amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1
403 Forbidden
Hiba http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/ trusty/main php5-readline amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1
403 Forbidden
Hiba http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/ trusty/main php5-cli amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1
403 Forbidden
Hiba http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/ trusty/main php5-mcrypt amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1
403 Forbidden
Hiba http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/ trusty/main php5-gd amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1
403 Forbidden
Hiba http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/ trusty/main libapache2-mod-php5 amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1
403 Forbidden
Hiba http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/ trusty/main php5-common amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1
403 Forbidden
Hiba http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/ trusty/main php5-curl amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1
403 Forbidden
E: Sikertelen letöltés: http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-mysql_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 403 Forbidden

E: Sikertelen letöltés: http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-readline_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 403 Forbidden

E: Sikertelen letöltés: http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-cli_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 403 Forbidden

E: Sikertelen letöltés: http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-mcrypt_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 403 Forbidden

E: Sikertelen letöltés: http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-gd_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 403 Forbidden

E: Sikertelen letöltés: http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/libapache2-mod-php5_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 403 Forbidden

E: Sikertelen letöltés: http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-common_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 403 Forbidden

E: Sikertelen letöltés: http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-curl_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 403 Forbidden

E: Nem lehet letölteni néhány archívumot. Próbálja futtatni az „apt-get update” parancsot, vagy használja a --fix-missing kapcsolót.

Mi a teendő, sajnos nem vagyok járta linuxban :-(

Linux verzió: Ubuntu 14.04.4 LTS (GNU/Linux 3.13.0-24-generic x86_64)

Köszönöm a segítségeteket előre is!
 
1

Szia,

Pepita · Júl. 2. (H), 16.27
- szerintem kiscsillió felesleges és formázatlan üzenet közül nemigen fogja senki kiválogatni a lényeget.

- php7.x alatt lehet, hogy hamarabb találnál segítséget, ma már nagyon kevesen / kevés helyen használunk 5.x-et.

- Az utolsó hibaüzi írt neked egy olyat, hogy apt-get update. Próbáltad? Hogyan és mi történt?

- Pontos php verzió is kellene.

- Esetleg próbáld meg így: apt-get update && apt-get install php5-curl

- Erre sajnos csak egyetlen helyes válasz létezik:
Mi a teendő, sajnos nem vagyok járta linuxban :-(
Akkor bízz meg egy hozzáértő rendszergazdát / üzemeltetőt.
Amennyiben ez egy éles szerver, akkor ez különösen nem vicc.

- Megnéztem egy legutóbbi Docker image-em, ami alatt hobby-fejlesztek, ez (FROM php:7.1-apache) nem tartalmaz curl telepítést, tehát az induló image már tartalmazza (mert van benne, ezt checkoltam). A hiányzó / nekem kellő plusz csomagokat a fentebbi update és install kombóval szoktam behúzni. (Én se értek nagyon hozzá, ezek csak fejlesztői konténerek, éleseket mindig megnézetem mással is.)
2

VÁLASZ

simisoma · Júl. 2. (H), 20.35
Igen, de sajnos csak PHP5 -ös verzióval fut egy program a szerveren.
Jönnek Pénteken hozzáértők megcsinálni,karbantartani, de nekem fontos lenne, hogy ez az opció hamarabb menjen.
Pontos PHP verzió: PHP Version 5.6.21
Kipróbáltam ezt is: apt-get update && apt-get install php5-curl. , de sajnos nem jártam sikerrel. :-(

Szóval azért kértem segítséget itt mert
Nem vagyok jártas Linuxban


Igen tudom a PHP7 tartalmazza alapból, de sajnos itt most PHP 5-ös verzión kellene megoldani.

Ha tudsz, tudtok kérlek segítsetek!

Köszönöm!
3

Valami jogosultsági probléma,

inf3rno · Júl. 2. (H), 22.05
Valami jogosultsági probléma, vagy ilyesmi lehet a háttérben. Nincs esetleg másik repo, ahonnan megpróbálhatnád? link