ugrás a tartalomhoz

On PHP Version Requirements

Hidvégi Gábor · 2015. Jan. 5. (H), 18.02
Miért érdemes folyamatosan frissíteni a PHP-t
 
1

Minimum requirement

Gixx · 2015. Jan. 7. (Sze), 17.09
Azért az érdekes, hogy a jelenlegi legfrissebb CodeIgniter csak PHP 5.1.6-ot igényel minimum. Ebből egyrészt az olvasható ki, hogy feltehetőleg egy csomó hasznos újdonságot nem használ - és itt nemcsak a late-static-bindingra, meg a többi nyalánkságra kell gondolni, hanem még függvények szintjén is van egy csomó "újdonság".

Másrészt felvetődik a kérdés, hogy vajon a legújabb (stabil) PHP verzióval valóban jól működik-e az alkalmazás? Mert az 5.1.6-os verzió óta azért megváltozott már egy-két dolog, és könnyen lehet, hogy egy függvény már nem egészen azt a kimenetet adja az új verzióval, mint régen. Példát hirtelen nem tudok mondani, de futottam már bele ilyenbe (pl false-ról, null-ra változott a hibát jelző visszatérési érték). Vagy éppen az évek alatt konkrétan ki is vették az adott függvényt a nyelvből.

Mondom mindezt úgy, hogy a kódot nem ismerem mélyrehatóan, és csak spekulatív feltételezésekbe bocsájtkozok. Ennek szellemében kéretik kezelni az írást :D
2

Ha van unit teszt (és lefedi,

szjanihu · 2015. Jan. 9. (P), 20.36
Ha van unit teszt (és lefedi, és valóban teszteli) és futtatják újabb PHP-vel, akkor megy. Ha nincs, akkor meg egyáltalán miért használja bárki is?