ugrás a tartalomhoz

Több Internet Explorer verzió egymás mellett

Hojtsy Gábor · 2003. Nov. 10. (H), 07.26
Korábban már hírt adtunk az evolt.org keretein belül működő böngésző archívumról, ahonnan korábbi Internet Explorer verziókat is beszerezhetünk. Eddig azonban úgy tűnt, hogy ezek futtatására egymás mellett nincs lehetőség. Az Insert Title Web Design cégnél most felfigyeltek arra, hogy az IE 6 kiadott "javított" verziója és az IE6 egymás mellett képes futni, és ebből a többi IE verzió párhuzamos futtatására is megoldást találtak.

A Microsoft azzal "lepleződött le", hogy az újonnan az Eolas per kimenetele miatt kiadott javított IE verziót a normál IE verzióval párhozamosan futtathatóan tette közzé. A különböző IE-k futtatását egy iexplore.exe.local állomány megléte teszi lehetővé (melynek tartalma nem lényeges).

Az Insert Title által közölt megoldással ezt kihasználva több böngésző verzió is futtatható egymás mellett, képernyőképeket is adnak ennek az érzékeltetésére. Egy bizonyos Luke Redpath három különböző szinű IE ikont is készített a különböző verziók megkülönböztetésének megkönnyítésére. Mindezeken felbuzdulva Ryan Parman kigyűjtötte a régebbi IE verziók futattásához szükséges állományokat, és közzétette az így már eléggé kompakt csomagokat. Az 5.01 SP2-es verzió 2.93MB, az 5.5 SP2-es 3.51MB. Ezzel szükségtelenné válik az evolt.org oldalon elérhető nagyobb csomagok beszerzése.

Fontosnak tartom megjegyezni, hogy mindezen hasznos információkhoz Simon Willison blogjának köszönhetően kerültünk.
 
1

Re: Több Internet Explorer verzió egymás mellett

Bártházi András · 2003. Nov. 10. (H), 10.18
Hmm. Ez tényleg működik... :) Egy érdekességet észrevettem azért: az IE5.0 about boxában a nagy IE5.0 grafika mellett azt írja ki, hogy 6.0-s verzió. Mindazonáltal "helyesen" IE5.0-ként működik. Akit érdekel a dolog, az időben szedje le, mivel valószínűleg az Internet Explorerek licenszelési feltételeibe ütközik a zip-ben való terjesztése a részeinek.
2

Re: Több Internet Explorer verzió egymás mellett

Hojtsy Gábor · 2003. Nov. 10. (H), 18.28
A kis zipeket hosztoló webhelyre időközben felkerült az IE 4.01 és az IE 3.0 is :) Így már nem lehet panasz, hogy nem használható régi IE böngésző...